BMW Parts at Partsgeek US

New Project '87 e30 325i

User avatar
gerrit323
E21 VIP
E21 VIP
Posts: 4340
Joined: Wed Dec 22, 2004 8:44 pm
My E21(s): '82 e21 323i hartge
Location: Belgium
Contact:

Re: New Project '87 e30 325i

Post by gerrit323 »

Depending from the build date your car should run the first version m1.0 bosh 0 261 200 081 motronic used upwards to 09/87 .. from 10/87 m1.1 bosh 0 261 200 153 was used.

Make sure to use the right motronic. The first one was for the 10.5 high compression engine .. the later one was for the 8.8/1 compression engine


1988 e30 320is
1992 Mazda mx5
1994 e36 m3
2015 Renault Mégane RS 275 trophy
2016 Fiat scudo workhorse
2019 Abarth esseesse



https://www.facebook.com/pages/Thielema ... 1227513195

e21Keith
E21 Fanatic
Posts: 381
Joined: Sun Jan 05, 2014 7:44 pm
My E21(s): '81 323i Manual

Re: New Project '87 e30 325i

Post by e21Keith »

I have the two sensors on the bell housing, checked them out and all the measurements look ok but that's still no guarantee that they are working in operation. Pair of new sensors was over £100 and the replacement ecu was just £35, so I'll see what happens.

Too wet and cold to play with it at the moment so I'll have to come back to it.

User avatar
Jeroen
Site Admin
Posts: 26526
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: New Project '87 e30 325i

Post by Jeroen »

That's correct, these are hall effect sensors so measuring impedance only gives you an indication, but no certainty at all. So still one of them could be bad. Are you sure they are hooked up correctly? Swapped connectors will make it fail as well.

As for the ECU, yup these are weak as well, so after triple checking everything it will be time to start swapping components.
Regards/groeten, Jeroen

We want your contributions in our E21 Facebook Group! Join, like, post & share!

e21Keith
E21 Fanatic
Posts: 381
Joined: Sun Jan 05, 2014 7:44 pm
My E21(s): '81 323i Manual

Re: New Project '87 e30 325i

Post by e21Keith »

The weather is better so time to play with my e30.

I fitted the replacement ECU but I have the same problem, I'm getting fuel but no spark :(

So where to next? I can send both the ECUs off for testing (both are an unknown quantity to me, never seen them on a running car), I can try new sensors. But reading up this early ML 3.3 is not a great setup, I could swap the whole lot for a later setup, but I need everything, the entire wiring loom, sensors, front pulley, HT leads.

I really want to get this car running so I can decide what to do with it next?

User avatar
Jeroen
Site Admin
Posts: 26526
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: New Project '87 e30 325i

Post by Jeroen »

I'd get a few cheap Facet aftermarket sensors through eBay and test first, that will only set you back a few tenners.
Regards/groeten, Jeroen

We want your contributions in our E21 Facebook Group! Join, like, post & share!

e21Keith
E21 Fanatic
Posts: 381
Joined: Sun Jan 05, 2014 7:44 pm
My E21(s): '81 323i Manual

Re: New Project '87 e30 325i

Post by e21Keith »

I just ordered a pair on new Bosch sensors. There is a third sensor on the front of the engine but its part of the loom, not sue how to get a new one, cant find a part number on the ETK.

User avatar
Jeroen
Site Admin
Posts: 26526
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: New Project '87 e30 325i

Post by Jeroen »

If you have the twins at the bell housing (early models only) the 3rd one at the front is only for diagnostic purposes like on the E21, no influence.
Regards/groeten, Jeroen

We want your contributions in our E21 Facebook Group! Join, like, post & share!

e21Keith
E21 Fanatic
Posts: 381
Joined: Sun Jan 05, 2014 7:44 pm
My E21(s): '81 323i Manual

Re: New Project '87 e30 325i

Post by e21Keith »

Great, that's really helpful. I recall having my 320 retuned for unleaded in about 1988, this involved the dealer retarding the ignition by about 4 degrees, they produced a printout, perhaps this was the purpose of the third sensor?
Parts ordered but I'm only getting mail deliveries every 2 days.

User avatar
Jeroen
Site Admin
Posts: 26526
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: New Project '87 e30 325i

Post by Jeroen »

could be! fingers crossed for speedy deliveries, running into several delays with international shipments myself as well
Regards/groeten, Jeroen

We want your contributions in our E21 Facebook Group! Join, like, post & share!

e21Keith
E21 Fanatic
Posts: 381
Joined: Sun Jan 05, 2014 7:44 pm
My E21(s): '81 323i Manual

Re: New Project '87 e30 325i

Post by e21Keith »

I could really use a definitive wiring diagram for the engine management on this car, I have a CD with just about everything on it except this one.

From What I can work out I have the Motronic ML 3.3 which was produced from 12/86-09/87. My car has a build date of 05/87. Suggestions please, is there somewhere I can download one?

shadyracer01
Upcoming E21 fanatic
Posts: 70
Joined: Tue Dec 05, 2017 7:39 pm
My E21(s): 323i '82 Y x2, 1 in resto, 1 now spares

Re: New Project '87 e30 325i

Post by shadyracer01 »

Keith my haynes manual from oct 1977 to sept 1987 has motronic wiring diagrams, Ive scanned pages and saved to pc to forward on to you if useful, doesnt state exactly which version it is but fits with your date of build. Send me pm if you want me to email across, I cant put pics up here unfortunately. Jim

e21Keith
E21 Fanatic
Posts: 381
Joined: Sun Jan 05, 2014 7:44 pm
My E21(s): '81 323i Manual

Re: New Project '87 e30 325i

Post by e21Keith »

Thanks Jim, PM sent.

In the meantime I'm trying to work out how the fuel system works? I have fuel getting into the fuel rail, and coming back through the return, so that all works, but no matter how much I crank the engine I can't get any fuel into the cylinders and still no spark. So either I have no pulses from the sensors on the bell housing or I have another fault in the ECU/wiring.

shadyracer01
Upcoming E21 fanatic
Posts: 70
Joined: Tue Dec 05, 2017 7:39 pm
My E21(s): 323i '82 Y x2, 1 in resto, 1 now spares

Re: New Project '87 e30 325i

Post by shadyracer01 »

Email with pics sent

User avatar
Jeroen
Site Admin
Posts: 26526
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: New Project '87 e30 325i

Post by Jeroen »

Looks like the fuel injectors are not operated. That can be caused by either a defective switching stage in the DME which you more or less ruled out by trying another DME, or by the sensors bringing things to a halt, either by being mixed up, or by a defective sensor. Hope your replacements are in real soon so you can test this theory.
Regards/groeten, Jeroen

We want your contributions in our E21 Facebook Group! Join, like, post & share!

e21Keith
E21 Fanatic
Posts: 381
Joined: Sun Jan 05, 2014 7:44 pm
My E21(s): '81 323i Manual

Re: New Project '87 e30 325i

Post by e21Keith »

I'm still not 100% sure the replacement ECU is OK, it was an ebay purchase, so I only know what the vendor told me, bearing in mind these are probably the most unreliable ECUs I have no idea if it really works or not? I really need a known good ECU or a car to try mine in!

I found a company that say they can test or even repair my ECU if faulty, but guess what, closed because of lockdown!

New sensors arrived today but it's raining so I'll have to wait :(

Post Reply